2016-10-09 1 views
-1

私はいくつかのWindowsサーバー上で動作するASP.NET Framework 4.0 WebFormsプロジェクトを持っています。私は、Linuxでプロジェクトをホストできるようにするために達成すべき目標について不思議です。プロジェクトをリファクタリングし、フレームワークのバージョンを4.5または4.6にアップグレードするとします。もし私が私のプロジェクトにWindows特有のコードを持っていないと思うのであれば、私は決してそのようなコードを持っていないか、Windows特有のプロパティを想定しないようにリファクタリングしているからです。私の質問は、Linuxで壊れていく.NETコンポーネントの主流は何ですか?古い.NETプロジェクトをLinuxに切り替えるには?

+1

私はWebFormsがLinuxでは動作しないと信じています。 .NET CoreまたはMonoを使用するには、MVCに移行する必要があります。 –

+1

@Uno nope。 WebFormsはMonoによってうまくサポートされています。 .NET CoreはASP.NET MVC Coreのみをサポートしているため、従来のASP.NET MVCとは異なります。 –

+0

@LexLiありがとう、私はMonoがWebFormsを実装したことに気付きませんでした。 –

答えて

1

Windows上でどのようにうまくアサートしても、LinuxとMono上でWebアプリケーションを実行すると、何が壊れているかがわかります。

この質問は広すぎます。私はMonoでASP.NET 4.x Webアプリケーションを実行することについてブログしました

Jexus WebサーバーとASP.NETクロスプラットフォーム 12月12日に膠東デベロッパーカンファレンス2015で講演するためにMingzhi Yiに招待されました。 JexusとASP.NETの十字架上の私の意見について...

https://blog.lextudio.com/2015/12/jexus-web-server-and-asp-net-cross-platform/

あなたは、.NET 4.6を注意する必要があり、それは.NETよりも遅く進化としてだけでなく、モノではサポートされない場合があります。

関連する問題