2016-08-09 26 views
0

これはStack Oveflowに関する私の最初の質問です。何か問題があった場合は私を許してください。 私はPythonを数ヶ月使っています。私は簡単なGUIを作ろうとしています。私はEasyGUIを見つけた。easyguiモジュールをインポートできません

私はモジュールをインポートしようとすると、私はエラーを取得:

Traceback (most recent call last): 
    File "C:/Users/matthewr/PycharmProjects/testing start/Tsting.py", line 1, in <module> 
    import easygui 
    File "C:\Users\matthewr\AppData\Local\Programs\Python\Python35-32\lib\site-packages\easygui\__init__.py", line 50, in <module> 
    from .boxes.choice_box import choicebox 
    File "C:\Users\matthewr\AppData\Local\Programs\Python\Python35-32\lib\site-packages\easygui\boxes\choice_box.py", line 76 
    except Exception, e: 
        ^
SyntaxError: invalid syntax 

私はimport easygui除いて私のコードですべてを消去しますが、エラーがまだアップしています。

私はpipを使用してアンインストールして再インストールしましたが、運はありません。

助けていただければ幸いです。

+1

あなたは_import easygui_だけを言うときに表示されるエラーを投稿できますか? –

+0

最初の光景は、私にはPythonバージョンの混乱があるように思えます。わからない。どのバージョンのPythonを使用していますか? – lrnzcig

+0

_easygui_をインポートしても例外エラーが表示されますか? –

答えて

5

はeasygui 0.96.0

を試してみて、私はしばらくの間easygui使用してきたが、私は新鮮なeasygui 0.98.0と3.5.2のインストールと新しいマシンに今日、正確に同じ問題を抱えていました。しかし、easygui 0.96.0は私のために働く。

  1. をPy 3.5.1に戻した場合と同じ問題です。
  2. easygui 0.97同じ問題はPy 3.5.1と3.5.2の両方で
  3. Py 3.5.2 easygui 0.96.0で - うまく動作します!

ピップアンeasygui

easygui ==をインストールPIP 0.96.0

+0

回答ありがとうございます**ありがとうございました**最新バージョンのバグでなければなりませんか? – MattR

0

ちょうど私のために動作しませんでした、まだ上記以来、この問題に引っかかって任意の他の人を助けるために:

がいますインストールに続いて!

pip uninstall easygui 

あなたが次に実行することは言うまで「正常にアンインストールeasygui-0.98.0」、二回それを行うには

が必要になる場合があります

sudo apt-get install python3-easygui 

は、この作業の理由IDKが、私はそれを想定していますバージョンピップの使用にいくつかのバグがあるからです!

注:これはubuntuマシンでのみ機能します!

関連する問題