2016-10-02 14 views
0

私はhttpモジュールを使用しようとしています。ちょっと見た後、これを修正するための唯一の2つのオプションは、私がやったモジュールをインポートするか、私のために廃止されたHTTP_PROVIDERSを使うことでした。Httpのプロバイダはありません!モジュールがインポートされました

私はここでそれをインポートした:

import { NgModule } from '@angular/core'; 
import { BrowserModule } from '@angular/platform-browser'; 
import { HttpModule } from "@angular/http"; 
import { AppComponent } from './app.component'; 

@NgModule({ 
    imports: [BrowserModule, HttpModule], 
    declarations: [AppComponent], 
    bootstrap: [AppComponent] 
}) 
export class AppModule { } 

をし、これが私のboot.ts

import 'core-js'; 
import 'zone.js/dist/zone'; 

import {bootstrap} from '@angular/platform-browser-dynamic'; 
import {ROUTER_PROVIDERS} from '@angular/router'; 
import {AppComponent} from './app.component'; 

bootstrap(AppComponent, [ 
    ROUTER_PROVIDERS 
]); 

であると私はここでそれを使用しようとしている:

import {Injectable} from '@angular/core'; 
import {Headers,Http} from '@angular/http'; 
@Injectable() 
export class ApiService { 
    constructor(private _http:Http){} 

} 

が、何らかの理由で私にエラーが表示されます:例外:エラー:未知(約束):例外:エラー:0:0 ORIGINAL E XCEPTION:Httpのプロバイダがありません!

ザ・は私が使用しているバージョンです:

"dependencies": { 
    "@angular/common": "2.0.0-rc.1", 
    "@angular/compiler": "2.0.0-rc.1", 
    "@angular/core": "2.0.0-rc.1", 
    "@angular/http": "^2.0.1", 
    "@angular/platform-browser": "2.0.0-rc.1", 
    "@angular/platform-browser-dynamic": "2.0.0-rc.1", 
    "@angular/router": "2.0.0-rc.1", 
    "es6-shim": "^0.35.0", 
    "reflect-metadata": "0.1.3", 
    "rxjs": "5.0.0-beta.6", 
    "systemjs": "^0.19.27", 
    "zone.js": "^0.6.12" 
    }, 

私はまだモジュールをインポートした後、このエラーを取得するなぜ任意の手掛かり?

+0

ダイレクトコピー/ PAあなたのpackage.jsonからste? '@ NgModule'は' rc.5'まで存在しませんでした。 'http:^ 2.0.1'もあり、残りは' rc.1'です。彼らは互換性がありません。これが新しいプロジェクトの場合は、ボード全体で '2.0.1 'から始めてください。 – cdbajorin

答えて

0

私が正しく覚えていれば、NgModuleがRC.5で導入されました。しかしあなたの依存関係はまだRC.1を使用しています。

Angular2の現在のバージョンは2.0.1です。 https://angular.io/docs/ts/latest/quickstart.html#!#create-and-configure

  • NPMが再び
  • テストコードをインストール
  • node_modulesとタイピングのディレクトリを削除し、

    • バックアップ作業ディレクトリ
    • 更新あなたのpackage.json:

      私は次のよう提案します

  • 関連する問題