2017-12-30 34 views
1

私はFirebaseを使用してアプリケーションを開発し、私はionic Cordova emulate androidを実行しようとすると、私はangularFireを使用せずにfirebaseバージョン"firebase": "^4.8.0"を使用し、次のエラー'@ firebase/app-types/private'モジュールが見つかりません。 Firebaseウェブアプリ

Cannot find module '@firebase/app-types/private'

を参照してくださいよ。 私は多くの研究を行いましたが、Firebase 4.8.1hereというユーザーが次の問題を発見しました。

これは私が使用しているversion 4.8.0をインストールすることで問題を解決しました。私は既にアンインストールして、firebaseを再インストールしようとしましたが、うまくいきませんでした。誰か助けてくれますか?次のように 完全なエラーは次のとおりです。

[11:18:34] typescript: Project/paystation/node_modules/@firebase/database/dist/esm/src/api/Database.d.ts, line: 4 Cannot find module '@firebase/app-types/private'.

L3: import { FirebaseApp } from '@firebase/app-types';

L4: import { FirebaseService } from '@firebase/app-types/private';

[11:18:34] typescript: ...station/node_modules/@firebase/database/dist/esm/src/core/AuthTokenProvider.d.ts, line: 17 Cannot find module '@firebase/app-types/private'.

L16: getToken(forceRefresh: boolean): Promise;

L17: addTokenChangeListener(listener: (token: string | null) => void): void;

L18: removeTokenChangeListener(listener: (token: string | null) => void): void;

Error: Failed to transpile program

at new BuildError (C:\Users\domy9\cordova_project\ionic_project\paystation\node_modules\@ionic\app-scripts\dist\util\errors.js:16:28) at C:\Users\domy9\cordova_project\ionic_project\paystation\node_modules\@ionic\app-scripts\dist\transpile.js:159:20 at Promise() at transpileWorker (C:\Users\domy9\cordova_project\ionic_project\paystation\node_modules\@ionic\app-scripts\dist\transpile.js:107:12) at Object.transpile (C:\Users\domy9\cordova_project\ionic_project\paystation\node_modules\@ionic\app-scripts\dist\transpile.js:64:12) at C:\Users\domy9\cordova_project\ionic_project\paystation\node_modules\@ionic\app-scripts\dist\build.js:109:82 at

+0

可能な重複してそれを修正 - Firebaseスローエラー](https://stackoverflow.com/questions/47949311/cannot-find-module-firebase-app-types-private-firebase-throws-error) – Sajeetharan

+0

同じエラーが発生しました –

答えて

0

私は同じ問題を抱えているが、私は[「プライベートfirebase /アプリ-タイプ/ @」モジュールを見つけることができませんの

npm install [email protected] 
関連する問題