2016-11-10 20 views
1

Xcode v8.1に更新され、ポッドをインストールしようとしています。しかし、一度インポートすると、XcodeはエラーModule Compiled with Swift 3.0 cannot be imported in Swift 3.0.1を返し、モジュールへのパスを返します。Cocoapods - Swift 3.0でコンパイルされたモジュールはSwift 3.0.1にインポートできません

私はUse Legacy Swift Language Versionと言ってみましたが、これで問題は解決しません。

これをコンパイルするために私が変更できるものは何ですか?私は、マイナーバージョンの変更がこのような大きな問題を引き起こすはずだと信じています。

ご協力いただきありがとうございます。

+0

**レガシー迅速な言語バージョン**設定YESの場合に動作していない、次にしてみてください**カルタゴ更新--platformのiOS --no-使用-バイナリ** –

+0

ポッドあなたはインストールしようとしていますか? –

答えて

0

これはほぼすべてのアップデートで発生します。すべてのポッドを最新バージョンにするには、ポッドがある端末でpod updateを試してください。

+0

はい。これは私がプロジェクトに追加している新しいポッドなので、最新です。 –

+0

@PhilipSawyerはこの質問を参照して、それが機能するかどうかを確認してください。 http://stackoverflow.com/questions/40250381/module-compiled-with-swift-3-0-cannot-be-imported-in-swift-3-0-1 –

0

プロジェクトをクリーンアップするだけです。

選択:製品 - >クリーン

関連する問題