2016-09-23 14 views
1

私は3.0への移行に問題があり、どのように攻撃するかわかりません。AWSのSwiftコンパイラエラーです。 swift 3.0を使用するとawsCoreを作成できませんでした。

post_install do |installer| 
    installer.pods_project.targets.each do |target| 
    target.build_configurations.each do |config| 
     config.build_settings['SWIFT_VERSION'] = '3.0' 
    end 
    end 
end 

私はOauthSiwftとSwiftchartsの3.0バージョンを指すことができました、しかし、AWSは何の枝を持っていないか、そのようなものは、私は次のように彼らの最新を指しています:

pod 'AWSAutoScaling' 
pod 'AWSCloudWatch' 
pod 'AWSCognito' 
pod 'AWSCognitoIdentityProvider' 
pod 'AWSDynamoDB' 
pod 'AWSEC2' 
pod 'AWSElasticLoadBalancing' 
pod 'AWSIoT' 
pod 'AWSKinesis' 
pod 'AWSLambda' 
pod 'AWSMachineLearning' 
pod 'AWSMobileAnalytics' 
pod 'AWSS3' 
pod 'AWSSES' 
pod 'AWSSimpleDB' 
pod 'AWSSNS' 
pod 'AWSSQS' 
私は次のように私のポッドを更新します

Error:

戦争:私は、私は次のエラーを取得する「構築」しかしときAWSが3.0に移行私の理解から

上部のningは既にNoに設定されていますが、まだエラーが表示されます。

ご協力いただければ幸いです!

+0

派生データフォルダを消去して再度実行します。それはGo to File - > Workspace setting @Tonatiuh Mendoza – KAR

+0

助けてくれてありがとう、残念なことに私はちょうどあなたが推奨したことをしたし、うまくいきませんでした。同じエラーが出ます。 –

+0

更新情報がある場合は、http://docs.aws.amazon.com/mobile/sdkforios/developerguide/setup.htmlを参照してください。 AWSCoreのポッドも追加してみてください。 @トナティアメンドーサ – KAR

答えて

0

私の問題が見つかりました。最新のバージョンではないココアポッドでした。私はBrewを使用していましたが、「ライブラリはインストールされていますがリンクされていません」というエラーが表示されました。

私は助けてくれてありがとう!

関連する問題